Fix for “LDAP login failed” error when trying to install Groupwise 7 Webaccess or GWIA on SLES Linux


To fix the LDAP login failed error when trying to install Groupwise 7 Webaccess or GWIA on SLES Linux:

Go to LDAP Group object for the server (not LDAP server object).  On the General tab, uncheck Require TLS for simple binds with Password > OK

Goto LDAP server object for the server, and on the General tab press Refresh NLDAP Server now

Install GWIA or Webaccess, and when installation is complete re-enable Require TLS for simple binds with Password and Refresh NLDAP Server.
 
The reason why is detailed in section 9.3.3 of the Groupwise 7 installation instructions
 

During installation, the WebAccess Installation program requires access to eDirectory by way of LDAP authentication. The LDAP Group object includes an option named Require TLS for Simple Binds with Password, which is enabled by default. With this option enabled, you must provide the LDAP server’s Trusted Root Certificate, which must be exported from the LDAP server, in order for LDAP authentication to take place (typically on port 636) during installation of the WebAccess.

Unless you already have SSL set up, an easier alternative is to disable Require TLS for Simple Binds with Passwords in ConsoleOne, which allows LDAP authentication to take place using clear text (typically on port 389), during installation of WebAccess. After disabling the option, restart eDirectory, install WebAccess, then re-enable Require TLS for Simple Binds with Password and restart eDirectory again.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: